CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Nov 17, 2011 8:12:15 pm
polekat73
icon



I have a problem with my screen flickering off and on. If i leave my pc on over night it stops flickering. But as soon as i restart it starts all over again. Can anyone help me solve this issue, it is very annoying.
Posted: Nov 17, 2011 10:07:34 pm
Calimero
icon



Have you updated the system? If you “don't know”, then what does uname -r say?

If you did not update, see this.
Posted: Nov 18, 2011 4:17:39 am
polekat73
icon



Yes i have sucessfully upgraded the complete system, even tried reinstalling the nvidia drivers. I have search many forums but so far nothing has fixed this. It might be that i have a glitchy video card. But I havent gave up yet.
Posted: Nov 19, 2011 12:18:22 am
Calimero
icon



What does that mean, “reinstalling the nvidia drivers”? Which drivers?

Tell me the name of the package(s) your reinstalled.
And give the result of uname -r as well.
Posted: Nov 19, 2011 11:43:37 pm
polekat73
icon



Ok definately have a software/driver issue here. I replaced the nvidia 8600 with an nvidia 8400 and i still have the same screen flicker. Plus i noticed at boot i get all these nouveau errors at boot, and my boot time is quite a bit longer then most of what ive read about. My boot time is less then 2 mins, but is not coming close to the 18sec boot, that i read on a post.



Motherboard: Asus m2n32-SLI-Deluxe
Ram: 8GB I forget the brand
Video Card: evga 8400 GS 512MB
Hard Drive: 240 gig seagate
Processor: AMD Athlon 64bit 5200+
CtkArch linux fully updated
Posted: Nov 19, 2011 11:48:30 pm
polekat73
icon



Sorry for got to add, this is the command i used to update the nvidia drivers  pacman -S xf86-video-nouveau
this had no effect.

And the answer to uname -r is 3.1.1-1-ARCH
Posted: Nov 21, 2011 8:47:37 am
Calimero
icon



Reinstalling nouveau was obviously going to do nothing, since it was updated along with the system.

Well, nouveau appears not to be supporting your card (assuming it has no hardware problem), so you may want to install the nvidia proprietary driver.

See the proprietary nvidia driver tutorial at the Documentation section of this website.

But wait, it could be your screen? You may want to check that first.
Posted: Nov 21, 2011 11:37:26 am
Cereal-Killer
icon



perhaps it would be a good idea to see the /var/log/Xorg.0.log ?

cat /var/log/Xorg.0.log | grep '(EE)'

this graphic card seems to be supported (see here) but the problem can be with sreen refresh...
Posted: Nov 23, 2011 10:21:36 pm
polekat73
icon



Calimero: Tried that nvidia driver and i lost my gui. In other words it would boot to a terminal command prompt where i could login and make changes and uninstall nvidia and reinstalled nouvea-dri and got my gui back. By gui I mean the for lack of better words, my desktop with the fbpanel and a mouse.

The weird thing I just found out if after I reboot and my screen starts to flicker, if I unplug the vga cable for 5 seconds and plug it back in the screen stops flickering and works fine until I reboot.

Cereal-Killer may have a point it could be the refresh rate.

I know the hardware is good cuz it works fine on windows7. And the monitor is working fine as well.
They were the first things I checked out before posting.

Calimero: I have spent days looking for a way to disable the monitor sleep function or low power mode, Im not quite sure what you would call it. But i would like my monitor to always be on, never shut off or go to sleep. I would appreciate any advise you could give me.
Posted: Nov 24, 2011 12:23:05 am
mandog
icon



Quote: polekat73 at Nov 23, 2011 10:21:36 pm
Calimero: Tried that nvidia driver and i lost my gui. In other words it would boot to a terminal command prompt where i could login and make changes and uninstall nvidia and reinstalled nouvea-dri and got my gui back. By gui I mean the for lack of better words, my desktop with the fbpanel and a mouse.

The weird thing I just found out if after I reboot and my screen starts to flicker, if I unplug the vga cable for 5 seconds and plug it back in the screen stops flickering and works fine until I reboot.

Cereal-Killer may have a point it could be the refresh rate.

I know the hardware is good cuz it works fine on windows7. And the monitor is working fine as well.
They were the first things I checked out before posting.

Calimero: I have spent days looking for a way to disable the monitor sleep function or low power mode, Im not quite sure what you would call it. But i would like my monitor to always be on, never shut off or go to sleep. I would appreciate any advise you could give me.



the nvidia 8600 nvidia card is perfectly ok with linux i use it on my desktop the reason you get a blank screen is the nouvea-dri is  still loading as it needs black listing also the nvidia driver needs to use xorg conf to work best and then you can go to the arch wiki and add the lines to force monitor to stay permantly on sorry i can't give it to you as i'm 7000 miles from my desktop.it was one of the 1st questions Misfit138 asked when he joint the ach linux forums.
this is the latest if not using xorg,conf
No blank screen

To disable blank screen after 10 mins of inactivity, create a file in
/etc/X11/xorg.conf.d called custom.conf with this code:

Section "ServerFlags"
# disable low-level screensaver and screen DPMS poweroff
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime"  "0"
EndSection
Posted: Nov 25, 2011 7:56:39 am
polekat73
icon



mandog: Thanx for the reply, I did what you said and it didnt work.
Posted: Nov 25, 2011 8:50:50 am
Cereal-Killer
icon



did you look at /var/log/Xorg.0.log ?

perhaps you can try to pass some options to the kernel at boot time, like explain here...
try this by editing kernel command line when the Grub menu is displayed (type "e"), and if it works, you can definitly add your settings in /boot/grub/menu.lst...
Posted: Nov 25, 2011 11:01:26 pm
polekat73
icon



Cereal-Killer: I checked out that log file, and to be honest with you. I didnt understand most of it.

However I did notice that DPMS is the screen power manager.
So I did a search on DPMS, and found this:

Disable DPMS and prevent screen from turning off
Type this into terminal "xset -dpms;xset s off" minus the quotes,

It worked great.

Thanks to Cereal-Killer & mandog for steering me in the right direction.

--Damian
Posted: Nov 26, 2011 10:02:33 am
Cereal-Killer
icon



I think you should enter this command on each boot, and CTKArch settings allready provide a DPMS option, that would be change...
open ~/.config/openbox/autostart , you have this:
BASH Code:
#éteint l'écran après 10mn d'inactivité ; screen switches off after 10mn idle
xset dpms 0 0 600

you don't need to delete this line; just comment it, and add yours:
BASH Code:
#éteint l'écran après 10mn d'inactivité ; screen switches off after 10mn idle
#xset dpms 0 0 600
 
#Disable DPMS and prevent screen from turning off
xset s off -dpms

perhaps it isn't necessary to add your line, and just comment the original line allready disable DPMS, you can test the 2 solutions...

PS: I hope you have a LCD screen; if it's a CRT screen, it's a very bad idea to let it always on with static picture (ie your desktop).
Posted: Nov 28, 2011 10:51:48 pm
polekat73
icon



Thanks Cereal-Killer. I added that line and tagged out the one.
I wondered what was reseting my DPMS everytime i rebooted.

As far as the screen flicker goes I'm ordering a new video card, and ATI HD card.
I think the screen flicker is a refresh rate problem with my monitor.
It can only do 2 resolutions 800x600 and 1024x768. And has been glichy with any deviations.
But in HD mode it has more options and in the past I have had less problems with HD.

It is and LCD screen, and I shut it off manually whenever I'm gone.

The reason I wanted to disable it is because everytime I watched a live video stream.(justin.tv)
My screen would go blank after 10mins.
But when I watched a movie that I downloaded it would be fine.
Posted: Nov 28, 2011 11:09:36 pm
Calimero
icon



You mean that the flash plugin does not interrupt the X screensaver, whereas mplayer does. Indeed. (flash sucks)
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst