CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Viewing profile for yannig.c
yannig.c



General
Joined:
2011-03-16
Posts made:
42
Homepage:
 
Status:
New member    
Email:
not public
Location:
bzh 
Contact
IRC  IRC:
 
Jabber  Jabber:
 
 
yannig.c's Signature:
yannig,
In forum "Community"
In topic "choix panel, pager"
Bon, je me fais à openbox,
après une soirée passée hier à lutter avec E17, dont la configuration m'est étrangère au possible, je dis vive la simplicité et je me range presque aux choix de calimero. presque, parce que comme wm il me va tout à fait, mais pour le panel et le pager je n'y trouve pas mon compte. C'est dû au fait que j'ai un petit écran, et peut-être aussi des choses moins objectives, goûts,habitudes ... bref.

PAGER
ça oui, il m'en faut un, et ipager ne fait pas l'affaire. ceux de E et Xfce me conviennent : je vois mes 3 bureaux, à quel logiciel appartient quelle fenètre, et avec la souris je peux prendre une fenètre sur un bureau la poser sur l'autre.
Est-ce qu'il y a un tel pager qui s'entend bien avec openbox, ou est-ce que je peux prendre celui d'xfce ou d'e17 sans devoir acheter le package complet ? (il y a un autre outils d'xfce que j'achèterait bien sans l'xfce complet : celui qui permet de règler la gestion d'énergie).

PANEL
j'aime les écrans presque vide ... je voudrais un panneau en haut à gauche avec le pager,l'heure, l'indicateur de batterie et celui de wicd. il recouvre les barres de titre et le bout de la barre de menus ou bien souvent il n'y a rien. (j'avais fait ça avec xfce). Comme openbox permet de mettre tous les boutons de fenêtre à gauche, cà ne dérange pas.
Et un deuxième panneau ou dock, autohide,à gauche de préférence, qui lance mes applications usuelles. Dans l'idéal, j'aimerais pouvoir en avoir un différent sur chaque bureau, mais ça je n'ai pas encore trouvé. quelqu'un connaît ?

sur les macs la barre de titre et la barre de menus ne font qu'un. c'est pas plus con, quand on pas trop de place. il y a des wm qui font ça sous linux ? ça peut se paramètrer dans openbox ? bon, ça c'est accessoire, si il reste un peu de temps.

Encore plus accessoire : est-ce qu'on peut avoir un wallpaper différent sur chaque bureau (ça c'est une question un peu à la con : sur un écran de 10" quand on voit le papier peint c'est qu'on est pas trop occupé !)

Mersi braz,

yannig,
Quote: Calimero at Mar 31, 2011 11:53:52 am
Tu sais que tu peux mettre fbpanel ou tint2 vertical à gauche en autohide si tu veux ?



Les deux consistent principalement en une longue barre de tache, ce que je trouve inutile (alt-tab), et un menu qui est accessible en cliquant sur le bureau. reste la zone de notification et l'heure : j'aime les voir tout le temps, mais ça m'embète d'occuper toute une largeur d'écran court pour ça !
Quote:

Openbox permet (voir les dernières lignes de ~/.config/openbox/rc.xml) de spécifier des applis par bureau, sur tous les bureaux, ou autres comme tu veux.
Mets-y tes panels selon tes bureaux…



j'essaierai ainsi de mettre xfpanel, quand j'aurai un peu d temps

Quote:

Par ailleurs, un enthousiaste m'a parlé de ce truc, regarde si ça te plaît :
https://launchpad.net/adeskbar



j'ai jeté un oeuil ... mais apparement il n'y a pas de pager. Je tenterai Xfpanel d'abord, et si il y a trop de dépendance ou que c'est trop le bazar à hybrider xfce et openbox j'y reviendrai.
Quote:

Pour un wallpaper par bureau virtuel openbox, on voit que tu n'as pas cherché…
https://bbs.archlinux.org/viewtopic.php?id=115375
(il faudra vraiment que j'arrête de donner le biberon, faire une recherche est à la portée de n'importe qui)



non je n'ai pas cherché loin pour un détail esthétique ... je posais la question au cas ou quelqu'un avait une solution simple déjà sous la main, que ça ne lui coûte pas trop de la transmettre ... merci de me donner ce lien, mais une solution si lourde ne convient pas à l'usage que je fais des bureaux.je switch beaucoup), Je me contenterai donc d'un papier peint, et je chercherai un pageur lisible.

*****La suite quand j'aurai du temps pour ça ... d'abord que la machine soit totalement fonctionnelle et puis on verra pour le confort. Il me reste à règler le problème de l'impression avant *****
In topic "0.8 soon?"
Bonjour,
Utilisant (peu) ces dernières années un ordi qui ne m'appartenait pas, j'avais mis quelque chose de plus "mainstream" dessus (lubuntu). Mais voilà tout à une fin, et comme la version n'était plus maintenu je me suis retrouvé avec un ordi inutilisable. J'ai ressortit ctkarch avec espoir ... mais non, on ne peut plus non plus s'en servir, sauf "En l'état". Hors elle a un peu vieilli ... je ne sais pas si on peut encore attendre une version 0.8, ou si tu es passé à autre chose ?
Du coup j'ai retroussé mes manches, j'ai installé arch en suivant le guide, Et me voilà avec une installation de base, une connexion internet qui marche, lxde en moche et quand yaourt aura fini de yaourter je devrais avoir un navigateur web ...
On est bien loin encore d'un système complètement fonctionnel.
Pourrais-tu diffuser la liste des fichiers, les fichiers de configuration éventuels permettants de faire d'une Arch "from scratch" un "CTK-DE", reprenant les fonctionnalités et l'aspect de ctkarch ? En gros, d'avoir une ctkarch 0.75, sans amélioration par rapport à la précédente mais actualisée.
Je me débrouille depuis 6 mois avec un liveUSB de Porteus, très bien dans le concept mais bancal dans la pratique, et j'aimerais bien mieux avoir une installation fixe, sobre et efficace.
Merci d'avance pour ton coups de pouce, qui sera sûrement utile pour d'autre aussi.
yannig,
In forum "User support"
In topic "[kernel one] migration (resolu)"
Bonjour,
ayant eu des problèmes de difficultés avec ma distribution précédente,m'a amener à essayer inlassablement de trouver autre chose. Pendant longtemps Arch m'a fait peur parce que  beaucoup de choses à apprendre, et bien si j'y avais consacrer le temps que j'ai passer à essayer tant de distros ben je n'aurai pas à vous poser des questions ...
Donc j'ai essayer hier ArchOne, spécialement prévu pour la machine qui est devant moi, et CTK. la clarté et le ton de l'explicologie autant que de l'instalation, le fait que ça parle français ... bref me v'là ici.

Donc ma première question : on trouve des kernels Arch taillés sur mesure pour mon ordinateur. Est-ce que je peux en prendre un tel qu'il est, ou est-ce que CTK à déjà un kernel modifié, et qu'il faut que je reproduise ces modifications sur le nouveau kernel ? Si oui, comment ?

Ensuite, est-ce que simplement je fait yaourt -a kernel26-one, et ça marche à la fin du yaourt ?

merci déjà pour votre aide,

yannig,
In topic "[cpufreq powersave] moniteur batterie (resolu)"
Bonsoir,

voilà ma deuxième question de migrateur :
l'utilitaire Ptbatterysystemtray a un onglet "ucpufreq", mais malheureusement chez moi il ne permet pas de changer le gouverneur. en fait il a plein de sous onglet prometteurs mais il ne permet rien.
Que faut-il bricoler pour que ça marche ?
Dans l'idéal je voudrais pouvoir changer le gouverneur sur "ondemand" ou "powersave", voir controler la vitesse à la main.
Et aussi pouvoir règler les paramètre d'économie d'énergie, quand et comment l'ordinateur se met en veille, ce qui se passe quand je ferme le couvercle, si l'adaptateur est brancher ou pas ... Comme avec le moniteur de batterie Xfce. est-ce qu'on peut faire ça de manière KISS ? peut-on installer xfce-powermanager sans xfce, ou y-a-t-il dautres animaux qui font tout ça bien ?

car je ne tient pas à installer Xfce : les essais de CTK que j'ai pu faire jusqu'ici me montre que les choix de logiciels de CTK sont souvent plus opportun que mes habitudes : je vais donc essayer de m'adapter à openbox.

La question de l'énergie est importante quand on n'a qu'une batterie de 3 cellules.
Aussi, je voudrais avoir la possibilité de faire hiberner la bête.
Merci pour les infos, avec l'aide de https://wiki.archlinux.org/index.php/Cpufreq et un peu de patience,tout marche avec cpufreq.
mais je ne m'en suis rendu compte qu'après avoir installer trayfreq, du coup j'ai pu faire la comparaison : et bienPtSystemtray sert en plus de bouton on/off/hybernate, ce dont j'avais besoin aussi.donc je vote pour lui.
Au fait, trayfreq je l'avais lancer à la main, mais si j'avais voulu qu'il démare tout seul au démarage, dans quel fichier aurais-je du ajouter une entrée ?

Autre question, puisqu'il y a un outil qui appel cpufreq d'installer dans CTKArch, pourquoi cpufreq n'y est pas dès le départ ? ça nuit au KISS, ou ce sera pour la 0.7 ?

Bon, je ne sait pas comment on met un sujet en [résolu], mais pour celui là c'est bon.
In topic "[ekiga] micro muet (resolu)"
Bonjour,

j'ai beoin d'un softphone dans mon ordi, pour alléger sérieusement les factures. Lequel vous parait le plus adapté avec CTK ?
sachant que j'ai déjà installé ekiga-lite : il ne prend pas le son du micro.
En regarant mieux dans alsamixer, j'ai vu MM sous le micro : je suposeque c'est mute. Dans le archwiki sur alsa ils disent : selectionner le micro et taper espace. J'ai fait, ça ne donne rien. Aussi, quand je tape une touche fonction (par exemple F1, l'aide serait bienvenue), alsamixer quitte. donc je n'y peux rien faire.

y-a-t'il une ligne de commande pour règler le problème, ou mieux un fix pour alsamixer ?

merci déjà,

yannig,


P.S. pour forum-manager :( ce message, rééditer après expérimentation, ne ressemble plus à l'original... mais je n'ai pas trouvé comment éditer le titre. [alsa] serait maintenant plus judicieux que [softphone]
Bon, j'ai fait ce qu'il fallait avec Alsamixer : clairement le micro marche on l'entend dans les hauts parleurs.
J'ai essayé toutes les configurations d'entrées de Ekiga , et ça ne marche toujours pas. la sortie par contre oui (j'entend les sonneries, et la voie de la madame "echo test").hda intel - PTLIB/ALSA.
Que peut-il bien manquer au système ?
ça, c'est déjà fait, c'est bien règlé. à priori le problème n'est plus dans alsa, c'est quelque part entre lui et ekiga ...
dans les paramètres je ne voix nul part Pulseaudio. Comme l'idée ne me parraissait pas bête je l'ai yaourté à tout hasard ... et bien ça ne change rien, j'ai juste encore alourdi mon système inutilement.
clairement, avec OSS ça ne marche pas j'ai un message d'erreur. avec "default - ptlib/alsa" ou "hda intel - ptlib/alsa", il fait comme si ça marchait. mais il est sourd !
j'ai consulté le forum arch, et a priori c'est un problème récurant ... beaucoup posent la question mais personne n'a la réponse.
à noter que j'ai installé twinkle aussi, et que je n'ai pas plus de résultat. Même moins: je n'ai pas de sortie.

la question est donc : qui a un softphone qui marche ? étudier un cas de réussite sera peut-être plus constructif que de chercher où ça ne marche pas.
alors de mon coté il n'y a pas de problème réseau : je reçois, c'est sûr.
Par contre le micro ne bouge pas.

Je n'ai pas accès aux paramètrags de la box, c'est celle d'un voisin qui m'a donné son "wep". Mais quand j'utilisais Mint (j'ai vraiment essayé n'importe quoi !) ekiga marchait sur cette même box. Ce qui marchait moins bien avec mint c'est le système de fichier, qui me changeait mon /home de propriétaire sans que je sache comment ni pourquoi ... c'est plus critique qu'un problème de softphone, d'où le changement.

à priori il n'y a pas de pare-feu. Mon voisin utilise un mac, skype youtube et office, et je ne crois pas que ses compétences aillent plus loin.

Donc, si le son marche bien chez toi, peux-tu me dire ce que tu as comme installation sonore. La base alsa/gstreamer de CTKArch ? PulseAudio ? autre chose que je ne connais pas ?
y-a-t-il des fichiers de configuration pour l'audio, que peut-être je pourrais reprendre de tes lignes ?

ma carte est le chipset HDA Intel commun sur les netbooks.

merci,
Bon, le problème est donc Audio. il se présente avec Ekiga, twinkle et skype.
Ekiga utlise ALSA/Gstreamer, twinkle Alsa et skype PulseAudio.

dans alsamixer tout semble ouvert, et quand je parle dans le micro on m'entend dans les hauts-parleurs.
J'ai fait Alsaconf.

que reste-t-il ? quels autres progammes interviennent sur le son ? Dbus ? X ?
ou y aurait-il une histoire de groupe, un groupe "capture" ou "mic" par exemple, qui ne serait pas
attribué par défaut à l'utilisateur ?
je viens d'essayer l'enregistrement : marche pas.

les deux micros (buil-in et jack) fonctionnent pourtant Si je met assez fort dans alsa, on entend bien dans le haut parleu ce que je dis au micro. Capture est à fond, non-muté. par contre sous la barre et au dessus des chiffre il y a  ------- . c'est le seul qui à ça. ça veut dire quoi ?

dans les pref>son>alsa>options>periph d'enregistrement de mhwave edit, j'ai "default". Que pourrais-je mettre d'autre ?
Enfin la réponse ...
Elle n'était pas sur archlinux.fr, ni sur le wiki Arch, ni sur linuxpedia, mes sources habituelles en dehors de ce forum, et c'est pourquoi j'ai mis si longtemps à trouver. Elle était bien plus près : man alsamixer. J'y est apris que ------ ça voulait dire off en langue alsa, et que labarre d'espace sert d'interupteur. ça y est, je peux causer dans le poste.
Donc, pas besoin de pulseaudio, de firmware etc ...

enfin [résolu] !

yannig,
In topic "[fstab] /dev/sdxx vs. UUID (resolu)"
Bonjour,

je voudrais savoir comment faire pour que le système perde la manie des UUID, et me fasse des lignes /dev/sdxxdans les fichiers fstab, mtab ... enfin qu'il parle une langue que je comprenne, quoi.


En fait il y a une partition que je veux monter en /home/shared (je trouve bête que chacun ai son répertoir vidéo et son répertoir musique), et je viens de m'apercevoir qu'il ne la monte pas. Résultat : j'ai simplement rempli un répertoire /shared de ma partition / home qui est maintenant saturée. Alors j'ouvre fstab ... et je ne comprend rien.

là avec les UUID si je remanie mon partitionnement (ce que j'ai fait au départ n'était pas forcément judicieux) le système sera perdu ...

Merci,

bon, d'accord, j'essaierai d'apprendre le langage uuid.

pour ce qui est de ma partition /home/shared j'ai compris : dans fstab la ligne était avant /home.
j'ai tout remis dans le bon ordre, maintenant ça marche.

[résolu] !
In topic "[pacman] betise (resolu)"
tient, comme si ce n'était pas assez dificile comme ça j'en rajoute !

Lors d'un yaourtage qui se présentait mal, avec impatience j'ai fermé le terminal ...
et maintenant yaourt me dit "pacman occupé, veuillez patienter. Hm. excusez-moi ... où est ce que je le délock ?

merci,
merci, ça marche, je re-yaourte.
In topic "[live-usb] systeme nomade (resolu)"
Bonjour,

je voudrais mettre CTKArch sur une clef sans utiliser toute la place. J'ai utiliser diverse méthode mais aucune n'a fonctionnée
1. Unetbootin : quelque part pendant le boot ça foire, je me retrouve avec une console root et ce n'est pas ce que je veux.

2. une méthode que calimero donne sur le forum archlinux.fr. Si je la respecte scrupuleusement, tout semble fonctionner jusqu'au moment du reboot, où la clef se fait snober, et je me retrouve au grub.

3. La première foi je n'avais PAS suivi scrupuleusement les instructions et j'avais fait une partition /sdb1 sur toute la clef avec gparted, fat32, avant de copier les fichiers comme expliqué : syslinux n'a pas voulu s'installer correctement sur la clef (ce n'était pas une fat il m'a dit).

pour mon média d'installation j'avais utiliser dd : ça marche bien mais je ne peux pas utiliser l'espace restant sur la clef. Or je voudrais y mettre un home persistant, des addons, et des répertoires synchronisés avec des répertoirs de mon /home.

une solution ?
Quote:

donc on revient au point de départ: on ne peut pas ajouter de partition...
l'astuce que tu donnes ici est donc la meilleure...



certainement, mais chez moi ça ne boot pas. C'est peut-être un problème de syslinux ? y-a-til une chance que ça marche mieux avec la prochaine version ?
pour l'instant, les seuls live que je peux installer avec Unetbootin sont  les dérivés de ubuntu. comme je ne réussi pas à faire marcher unetbootin avec arch, j'utilise ma clef "parted mmagic" ... que j'ai dû faire avec dd !

j'ai effectivement besoin que la partition soit visible sur n'importe quelle machine, je compte même y mettre des "portable apps" pour pouvoir lire mes mails et accéder à mes documents sur les machines publiques que je ne peux pas booter, qu'elles soient pommes ou grosoft. ou peut-être il vaudrait mieux que j'ymette des virtalbox avec CTK ? bon c'est pour plus tard ça, quand déjà ma machine sera satisfaisante. déjà, elle est (quasi) fonctionnelle c'est pas mal.
Quote: Calimero at Mar 31, 2011 11:44:26 am

Je ne devrais pas m'avancer, ça te conforte dans une habitude exécrable de simplement dire "ça marche pas" sans rien préciser.
Mais voilà ce que j'ai imaginé qu'il t'est arrivé : syslinux /dev/sdb a donné des erreurs (paquet mtools manquant, indiqué en optdepends) et tu les as ignorées au lieu de les résoudre et de recommencer, ou encore tu as une erreur au boot style config manquante (mais tu ne le dis pas, grr).




ah là ! comment on se forme un préjuger, et à quelle vitesse l'imagination prend ensuite le pas sur la réalité.

"rien que des faits" comme disait le professeur Nesterenko:

sylinux ne m'envoie pas de message d'erreur, tout semble normal. Personne ne m'envoie de message d'erreur, mais au moment du boot ... je me retrouve sur le hd. ça ressemble au topic "[grub] live-cd non reconnu (resolu)", mais sur usb. aussi la solution sera peut-être la même la même : attendre 0.7 ?

EDIT : non, j'ai essayé avec 0.7rc1 c'est pareil

J'ai essayé de voir le flag "boot" avec gparted : il n'y est pas, mais avec la clef sans table de partition gparted ne permet pas de le gérer.
cfdisk me dit erreur fatale, fdisk je ne sais plus ce qu'il dit mais il ne fait rien.

D'où réflexion : certainement la solution que tu propose est la bonne dans certains cas, mais un système de fichier que les partitionneurs courants ne savent pas par quel bout prendre ça présente quand même quelques inconvénients.
---------------------------------------
D'où les tâtonnements suivants, qui explique patiellement mon silence radio de ces derniers jours. Je ne transcrits que ce qui ne m'a pas encore mené dans une impasse :

-faire une partition /sdb1 vfat sur toute la clef (8g). flag boot.
-copier les fichiers dessus depuis l'iso en suivant la méthode calimero
-installer grub2 à partir de mon système installé sur hd.

PHP Code:
grub-install /dev/sdb
 
Installation finished. No error reported.
 
grub-mkconfig -o /media/sd8g/boot/grub/grub.cfg
 
Generating grub.cfg ...
Found linux image: /boot/vmlinuz26
Found initrd image: /boot/kernel26.img
  No volume groups found
Found Bodhi Linux (10.04) on /dev/sda2
done


avant de faire  grub-mkconfig j'ai renomé /etc/grub.d/40_custom en 09_custom, pour que l'entrée "Archlive" soit au début.

Tout marche bien jusqu'au grub, mais je n'arrive pas à booter archlive. En fait j'aurais besoin d'aide pour faire le "menuentry" du live. voici le miens c'est bien le bout de mes compétences :

PHP Code:
menuentry "CTK Archlive 0.7rc1" --class archlinux --class gnu-linux --class gnu --class os {
insmod vfat
set root='(hd1,1)'
#      EF0C-242F est l'uuid obtenu avec blkid, mais apparement ça ne va pas
search --fs-uuid --set EF0C-242F
echo Loading Archlive ...
linux /boot/vmlinuz26 root=/dev/sdb1 ro  locale=fr_FR.UTF-8 keymap=fr-pc,fr- quiet
echo Loading initial ramdisk ... archiso
initrd /boot/archiso.img
}


J'ai pensé que peut-être ce serait plus simple de mettre l'iso sur la clef, et que grub appel le syslinux de l'iso (chainloading,j'ai lu que ça faisait parti des capacité de grub2). Mais même problème, je n'ai pas encore reussi à faire un menuentry qui permette de booter un iso, et j'aurai besoin de vos compétences.

D'autre part, le fait d'avoir le système directement sur la clef et non dans l'iso me parait plus simple, si je dois manipuler des fichiers depuis un autre système (le CTKArch de mon disque dur le plus souvent). Mais peut-être il y a des arguments pour l'ISO ...
En tout cas l'argument "ça marche" me convaincra, que ce soit pour l'ISO où pour les fichiers "libres".

Merci déjà de votre aide, je ne peux pas aller plus loin seul.
Quote: Calimero at Apr 05, 2011 8:15:14 pm

Y'a pas de souci à utiliser grub2 comme bootloader si on veut. Chez moi, la méthode syslinux fonctionne.
Note bien qu'il faut root-image.sqfs à la racine de la partition ;



ça c'est bon
Quote:

mais avant tout, je remarque l'absence de archisolabel=Label-de-la-partition dans ton entrée grub2 !!



là, cette fois c'est fait. Et j'ai aussi corrigé le uuid.
Quote:

Donc tu as certainement un joli shell [ramfs /]# au boot.



ça n'allait pas jusque là . (error : file not found / error : no such device as [uuid]/ Loading Archlive / error : file not found / loading initial ramdisk ... archiso / error : you need to load kernel first).
par contre maintenant, je l'ai. ça dis comme ça :
PHP Code:
loading initramfs
starting udevd.
sd 4:0:0:0[sdb]assuming drive cache : write through
sd 4:0:0:0[sdb]assuming drive cache : write through
sd 4:0:0:0[sdb]assuming drive cache : write through
 
ERROR : boot device didn't show up after 30 seconds
Falling back to interactive prompt
you can try ...
[ramfs/]#


Quote:

J'avais pourtant bien spécifié de mettre le bon label à la partition dans mon post original :
forums.archlinux.fr/post57749.html#p57749
(note, en suivant ceci pour la 0.7, remplacer CTKArch6 par CTKArch7)



j'ai bien renommé la partition. à noter que losque je fait blkid, ou dans pcmanfm, la partition apparait comme "CTKARCH7", bien que j'ai fait et refait dosfslabel /dev/sdb1 CTKArch7. ça viendrait de là ?
Quote:

Est-ce que tu avais le menu de boot Français/English avec le logo arch et tout quand tu avais vraiment suivi ceci ?
Où est-ce que ça coinçait exactement ?? Autrement dit, quelle était la dernière chose que tu pouvais voir à l'écran avant que le boot s'arrête ?


Je ne suis pas encore arrivé au menu. pour l'instant le dernier mot c'est [ramfs/]#
oui ça marche, sûr, mais chez moi ça ne boot pas.
Sans quoi je ne t'agacerais plus avec cette question.

Bon, je ne suis pas pressé, je ne toucherai de toute façon pas à l'ordi avant dimanche ou lundi donc finis tranquille la 0.7 avant ... mais après si tu (ou quelqu'un d'autre) peut m'aider à faire le "menuentry" grub pour booter sur l'iso 0.7,(ou sur les fichiers copiés selon ta méthode) ça serait magnifique. Car celui que j'ai envoyé plus haut, avec en plus la ligne archisolabel, est le bout de mes compétences dans ce domaine.
Finalement je me dis que l'iso c'est pas plus mal, les fichiers risque moins d'être écornés par un autre système si je balade ma clef, non ?
Et oui je m'entête dans le grub, mais une partition maniable avec gparted ou cfdisk c'est quand même un avantage notoire à mon sens.

yannig,
Wah !

ça y est, voilà l'entrée grub qui marche :
PHP Code:
menuentry "CTK Archlive 0.7" --class archlinux --class gnu-linux --class gnu --class os {
insmod vfat
set root='(hd1,1)'
search --label --no-floppy --set CTKArch7
echo Loading Archlive ...
linux /boot/vmlinuz26 root=/dev/disk/by-label/CTKArch7 ro archisolabel=CTKArch7 locale=fr_FR.UTF-8 keymap=fr-pc,fr- quiet
echo Loading initial ramdisk ... archiso
initrd /boot/archiso.img
}


avec ça je lance CTKArchlive 0.7, copiée sur une partition /sdb1 vfat qui est agréée par gparted !
"disk by label" fonctionne aussi bien que uuid, mieux puisque c'est lisible donc moins sujet à erreurs. Merci Archwiki "grub2".

Le sujet "système nomade" n'est pas clos pour autant, j'aurai sans doute besoin d'éclaircissement concernant les add-ons (la première lecture de la doc me laisse des "?").Je reviendrai quand je calerai sur un point précis. à bientôt !
Si une question : dans ce que j'ai survolé de la doc tu dis qu'il ne faut pas toucher aux init scripts, tu donnes une explication sur comment faire à la place que je n'ai pas compris. Donc, prenons un exemple concrêt : si je veux mettre cpufreq, et aussi le daemon "cups", dans un addon. Dans quel fichier je les appel. Note que cet fois je questionne avant d'avoir mis les mains dans le gras, mais juste j'aimerais un exemple concrêt pour comprendre l'explication théorique que tu donnes. Voilà.

Merci d'avance,

yannig,
d'accord, mais pour que cpufreq fonctionne il faut que les modules "conservative" "powersave" ... soit chargés dans le noyau. est-ce que je peux mettre une ligne "modprobe" dans ce même fichier, ou faut-il la mettre ailleurs ?

merci,

EDIT : ah oui, je ne sais pas si c'est la olution officielle mais ça marche de mettre les modprobe là.
In topic "[GDM]borné"
pour disposer d'une session "guest" pour prêter mon ordinateur, pourpouvoir me connecter en root et pouvoir ré-utiliser e17 (pour le prêt, aussi peut-être pour moi même si je commence à me faire à openbox),j'ai installé GDM. j'ai suivi les recommandations trouvées dans un autre post de ce forum :
Quote:

How did you configure gdm's startup? In DAEMONS in rc.conf, I guess… The fast and unclean method.
You should rather remove gdm from the daemons, and change /etc/inittab as follows:

x:5:once:/bin/su arch -l -c "/bin/bash --login -c startx &>/dev/null" &>/dev/null
becomes / devient :
x:5:respawn:/usr/sbin/gdm -nodaemon



MAIS :
-je ne peux pas me connecter en root
-je ne peux pas me connecter avec un autre utilisateur que j'ai créé avec adduser : seulement avec celui que j'ai créé en installant CTK.
c'est bien la peine d'avoir GDM ... Comment je peut lui ouvrir un peu l'esprit ?

merci,
Pour l'instant son seul groupe est users. comment je peux voir quelssont les groupes auquel appartient mon premier utilisateur, faire un copier-coller vers le nouveau ? car effectivement il faut qu'il puisse se servir d'une imprimante, internet ... mais il ne faudrait pas qu'il puisse yaourter.

Pour l'impossibilité de faire une session graphique en root, je ne savais pas. Avec Zenwalk ça se faisait très bien, mais c'est vrai que ce n'est pas utile tous les jours. mais il y a des programes tels Unetbootin et startup-manager qui ne veulent pas fonctionner, et je supposais qu'avec une connexion root ça aurait des chances de mieux marcher ...
Si c'est la 0.6 ? il y en a une nouvelle après, que je n'ai pas vu ?
In topic "[xkill] raccourci xkill ? (resolu)"
Bonjour,

dans le menu des fenêtres (clic droit sur la barre de titre), il n'y a pas le "Kill" si pratique quand une application plante (par exemple, là j'ai un mhwaveedit qui ne veut plus bouger). y-a-t-il un autre chemin simple pour arriver à ce résultat, ou mieux peut-on ajouter cette option à ce menu de fenêtres ?

merci,


yannig, killer occasionnel
désolé de vous avoir dérangé pour rien. Depuis j'ai vu : il y a la touche de racourci alt-ctrl-K qui est
configurée pour X-Kill. Je l'ai changé en super-Backspace ça va mieux dans ma logique. Mais c'est vrai
que pour ce qui ne connaisse pas c'est bien quand c'esst écri dans le menu. La gueule de l'ordi plus
ou moins partagé, couvert d'étiquettes pour expliquer les manip courantes !
bien sûr, quand tes doigts et ton clavier deviennent une prolongation de tes synapses.
Mais pour les gens qui utilisent l'ordinateur occasionnelement c'est différent. Ceci-dit ceux là n'utilise pas Arch en général ... mais des fois ils m'empruntent mon ordi.
comme ce sont ces gens là qui ont la plus forte propension à provoquer un plantage, il est bon qu'ils trouvent XKill ! mais ne te ile pas, je collerai une étiquette de plus à coté du clavier !
In topic "[keyboard layout] changement (resolu)"
bonsoir,

je prépare une clef ctk nomade, avec laquelle je voyage entre l'allemagne et le portugal ... il faut donc que je puisse passer d'une disposition de clavier à l'autre (français allemand portugais anglais espagnol, pc et mac) facilement. y-a-til un petit utilitaire que je pourrai avoir dans le systray ou à la rigueur sur le bureau, pour passer de l'un à l'autre à chaque démarage facilement ? je sais bien faire ça avec xfce, mais là que je me suis fais à openbox, j'aimerais quelque chose qui marche avec ... une idée ?
merci pour les infos. Voilà ce qui en sort :

xxkb : ça ne fait rien
fbxkb : un joli drapeau français dans le systray, mais pas la possibilité de switcher. Faut-il indiquer ailleurs dans le système un choix de plusieurs layout ?

l'idée de faire des racourcis clavier pour définir des dispositions de clavier est bonne ... si on ne change pas de clavier

j'essayerai les entrées dans le menu openbox, ça me parait le plus simple. mais comment je fais pour les variantes, par exemple pour un clavier allemand de mac ?

plop, kesako ?pour les ordis où je ne peux pas booter CTKArch, j'emmène portable virtualbox sur la clef. Par contre je suis prenneur si quelqu'un sait où trouver portable virtalbox pour macosX.
bon, j'ai fais un menu "clavier" dans le menu d'openbox comme l'indique cerealkiller. ça marche très bien, c'est pratique et très facile à faire. Tout pour plaire.

[resolu !]
In topic "[systeme nomade] utilisation addons (resolu)"
bon, je m'y remet. parce qu'un netbook c'est trop lourd dans mon bagage, il faut que je virtualise tout sur un sd, et je vend le poid.
c'est la suite d'un topic commencer dans user support il y a du temps, je fais un nouveau topic parce que là je veux causer addons.

donc me revoilà  avec deux questions précises

- D'abord, dans le script "mkaddon", quand on a mis assez de package, comment quitter la liste qui me re-sert toujours une flèche, pour revenir au menu et choisir "finish" ?

-ensuite, plus important :

Quote:


Dans l'add-on, un fichier addons/rc/bidule.sh (qui bien entendu doit être exécutable), et contenir :

BASH Code:
#!/bin/sh
/etc/rc.d/cpufreq start
/etc/rc.d/cups start




bon, mais mkaddon me donne la possibilité de faire install_pkg ou cp_change : je ne voit nul part comment on met simplement un fichier ou répertoire dans un addon. Je n'ai pas vu la marche à suivre pour ça non plus dans la documentation sur les addons, ni trouvé de document accessible concernant mksquashfs dans le wiki archlinux.
Merci d'avance pour l'explicologie !

yannig,
merci pour ton éclairage sur l'usage du shell, je n'avais pas compris à quoi qu'il servait. je m'y met

par contre pour l'autre question ? comment revenir au menu du script quand on a rajouté assez de packages ?

EDIT : bon, je m'en sors trè bien avec cp_changes, juste il paraît que c'est pas très propre et pas terrible pour partager les addons ensuite.
ne t'énerves pas, pour le shell j'ai compris je m'en sors très bien.
La question qui reste et que tu ne veux pas entendre (elle a déjà été posée :par quelqu'un)

QUAND TU ENTRE UNE LISTE DE PACKAGES POUR L'ADDON
APRES CHAQUE PACKAGE RAJOUTE TU FAIS ENTREE
UNE AUTRE FLECHE APPARAIT
QUAND TU NE VEUX PLUS DE FLECHE, QUE FAIS-TU POUR REVENIR AU MENU QUI PERMET DE FINIR L'ADDON ?

j'ai essayé exit quit done back end ... ctrl-c ctrl-x ctrl-z esc rien n'y fait, toujours j'ai le droit de rajouter des packages ! mais je ne veux pas mettre tout arch dans l'addon !
In forum "Add-ons"
In topic "Add-on négatif"
Bonjour,

je voudrais faire un addon négatif : en fait enlever ce qui ne me sert pas (tux racer, abiword, gnumeric, audacious, et leurs dépendances). Il faut bien que je gagne un peu de place, puisque par ailleur j'ai besoin d'open office avec 4 language-packs !
J'ai essayé de faire un adon en copiant les changement fait en live : ça ne marche pas, au démarage suivant mes packages sont revenus.

la solution des fichiers wh. , c'est bien pour des fichiers, mais pour désinstaller des packages entiers c'est comment?

merci,
In topic "addon daemons"
j'ai fait un petit addon qui lance au démarage des daemons utiles : cpufreq, wicd, cups et openntpd. Openntpd et wicd sont déjà inclus dans la live mais ils ne démaraient pas tous seul.
cpufreq ça marche très bien, il charge les modules performance, conservative et powersave, et met conservative par défaut.
wicd aussi ça va.

pour openntpd : cela ralenti considérablement le boot : une bonne dizaine de seconde.je suppose que c'est parce qu'il attend une connexion.

calimero n'aime pas éxécuter des choses en parallèle, il démontre bien comment ça ne va pas plus vite. Mais peut-être, en autorisant l'ordinateur à faire autre chose pendant cette attente, à défaut de gagner du temps on en perdrait moins ?
comment je peux donc, dans mon fichier /addon/rc/bazik.sh, mettre "openntpd start" enarrière-plan ?

pour cups, je n'ai pas réussi à le faire fonctionner avec CTKArch. J'ai pourtant installer cups, cups-pdf et system-config-printer-common, comme je l'ai vu dans un autre thread du forum. mais l'utilisation du gestionnaire d'impression dans le menu me retourne une "opération non supportée".
et l'usage de localhost:631 n'a pas été concluant (où trouver les "ppd" ?).
In forum "Bugs"
In topic "[0.7rc1] hibernation et amnesie (resolu)"
Bonsoir,

pour éteindre mon ordinateur j'utilise un clic droit sur l'icône de batterie, et apparait un menu classique avec halt, reboot, suspend, hibernate. Tout ça marche très bien, et quand je le fais hiberner il se conduit comme je l'ai toujours vu faire avec n'importe quel linux ... mais au réveil, il "oublie" qu'il y avait une session en cours, et redémare comme une nouvelle journée quand le réveil sonne ... donc l'hibernation n'a plus d'intérêt. Comment je peux lui rendre la mémoire ?

détail mineurs, j'aimerais aussi pouvoir éteindre l'ordinateur avec le bouton, et le faire hiberner avec la touche Zzzz. ça se règle quelque part ?

merci,
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst