CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Sep 22, 2011 2:01:23 am
heretik
icon



bonjour,

de retour aprés une semaine de congés, j'ai eu hier aprés midi un plantage dû à une coupure de courant causée par des travaux dans ma rue...

j'écoutais de la musique et mettais à jour ma ctkarch...

Ctk se lance, "normalement, jusqu'au moment de passer en mode graphique ...
à ce moment, à l'invite s'affiche ceci:

ctkarch login:[11200064] phy0 rt2800_wait_updma_ready: error - UPDMA Tx/Rx busy aborting

et ensuite plusieurs lignes du même genre qui finissent toutes par : rt2800pci_set_device_state: error-device failed to enter state 4(-5)

en faisant ctrl-c je 'reprends la main' et arrive à naviguer sur le disque dur, (mais les lignes de code reviennent s'afficher aprés l'invite )

là je suis sur le live et on dirait que le hdd est toujours présent :)  tant mieux, mais...

-est-il possible de "sauver" mon installation soit en réinstallant depuis le live sans toucher à mon "home"

ou en passant par la ligne de commande en sachant quand même que je ne suis pas un pro et ne sais pas lancer une connexion réseau en ligne de commande ni même comment procéder ... :/ ... ça m'apprendra à tout faire en mode graphique... -_-

ce n'est sans doute ...ou plutôt j'espère que ce n'est qu'un problème de fichiers de config qui à sauté quelque part.... je croise les doigts...

Merci de votre aide pour m'aider à me sortir de ce mauvais pas...

edit: je viens d'essayer avec alt F2 et xterm dans la fenêtre, ça fonctionne... je vais pouvoir arrêter le système proprement
!!__metal__!!
Posted: Sep 22, 2011 11:53:32 am
Calimero
icon



Ces erreurs concernent une carte réseau realtek.
Elles étaient certainement présentes avant, mais tu ne les voyais pas. C'est venu avec la mise à jour des initscripts.
Il faut rajouter loglevel=4 aux paramètres de boot du noyau dans menu.lst, c'est tout.

Pourquoi parles-tu de réinstaller ? (quoi exactement d'ailleurs ?)
Il n'y a rien à sauver, tout va bien. Ton disque et tes données en tout cas. Et l'install aussi, probablement.

Pourquoi est-ce que tu ne finis pas simplement la mise à jour ?? Ça ne peut pas marcher avec un système seulement à moitié à jour, donc finis-la. (ne va pas croire que c'est cassé)
Hop, pacman -Syu. Faut finir ce qui est a été interrompu.
Posted: Sep 22, 2011 2:52:07 pm
heretik
icon



Il faut rajouter loglevel=4 aux paramètres de boot du noyau dans menu.lst, c'est tout.

"Pourquoi parles-tu de réinstaller ? (quoi exactement d'ailleurs ?)
Il n'y a rien à sauver, tout va bien. Ton disque et tes données en tout cas. Et l'install aussi, probablement."

en effet, depuis le live, je vois que tout à l'air d'être là...je dois sans doute être d'un naturel pessimiste... :)  et en cas de problème j'imagine toujours le pire...peut être à cause de certaines de mes précédentes expériences avec d'autres distro comme debian, ou ubuntu... :)

"Pourquoi est-ce que tu ne finis pas simplement la mise à jour ?? Ça ne peut pas marcher avec un système seulement à moitié à jour, donc finis-la. (ne va pas croire que c'est cassé)
Hop, pacman -Syu. Faut finir ce qui est a été interrompu."

j'ai bien sur fait la mise à jour... en mode console puisque depuis le crash je n'ai plus de mode graphique...
et lorsque j'ai rebooté, je suis arrivé sur tty4 qui me demande mon login, puis mon mot de passe, et puis rien... si je tape startx  ça me dit...

"cannot move old log file "/var/log/xorg.0.log" to "/var/log/xorg.0.log.old" puis
xinit: giving up
xinit: unable to connect to x server: no such file or directory
xinit server error

et je me retrouve à l'invite de commande $

pour le moment, je cherche donc à pouvoir retrouver le mode graphique (je me connecte depuis le livecd pour plus de facilité ) mais j'avoue patauger devant mes lacunes concernant les entrailles de ctkarch et de linux en général ...
"avant" sur les distro " à l'ancienne", je bidouillais juste xorg.conf mais là j'ai du mal... même si je lis beaucoup sur les forums, en fait comme je ne sais pas vraiment quoi chercher, bin forcément, je ne trouve pas...

il faudrait que je m'achète un bouquin ou trouve un bon pdf qui explique arch de A à Z, je verrais ça dès que possible ;)

j'espère ne pas trop abuser de votre temps, j'imagine que mon ignorance et mes questions doivent enerver, et je m'en excuse si c'est le cas ;)

Merci à toi pour ton aide, c'est sympa


!!__metal__!!
Posted: Sep 22, 2011 8:56:30 pm
Calimero
icon



Je suggère de résoudre le premier problème évident qui se présente. Commençons par enlever ces logs dont les permissions ne correspondent pas :
[root@machine]# rm /var/log/xorg.0.log*

Ça peut suffire.
Il suffit d'un détail pour que Xorg ne se lance pas. (et que tu aies peur d'avoir tout perdu)

Et je t'arrête tout de suite : ce n'est pas xorg.conf qu'il faut aller toucher, puisque ça fonctionnait très bien avant sans.
Ne cherche pas les problèmes ailleurs, ils sont sous tes yeux quand tu fais startx.
Posted: Sep 22, 2011 11:43:28 pm
heretik
icon



alors...

- j'ai exécuté la commande rm, et c'est à nouveau pareil lorsque les log reviennent aprés un startx,
même message "fatal server error : cannot move old log file..." j'ai même ré essayé en laissant les log mais en modifiant les droits, toujours même résultat.

-lorsque je fais startx, même message : échec de l'ouverture de l'affichage depuis la variable d'environnement DISPLAY...

-si je tape openbox-session, ça dit :  unable to connect to x server: no such file or directory. xinit :giving up...

maiintenant (depuis le rm des log) j'ai un bip en root aprés chaque commande

par contre j'ai remarqué que si je tape startx en root (je sais, ce n'est pas un truc à faire... mais bon... ) j'ai un écran noir ...qui disparait en faisant c alt+backspace

voilà où j'en suis...

encore merci du temps que tu me consacres, bonne soirée...arf, bonne nuit  plutôt :)

,
!!__metal__!!
Posted: Sep 23, 2011 6:44:27 am
Cereal-Killer
icon



tu peux donner le résultat de cette commande:

ls -la /usr/bin/Xorg

"si je tape startx en root (je sais, ce n'est pas un truc à faire... mais bon... ) j'ai un écran noir ...qui disparait en faisant c alt+backspace "
avec un curseur en forme de croix, c'est ça?
Posted: Sep 23, 2011 6:44:58 am
Calimero
icon



Connecte-toi avec ton utilisateur et voyons ce que dit la commande groups.

Sinon, ton explication de ce qui se passe avec startx (une fois les log enlevés) n'est pas claire.
Tu peux donner ce qui sort en tapant startx ?
Astuce pour mettre la sortie sur pastebin plutôt que dans le term : startx |& pastebin

Cereal, son X fonctionne. Je dirais que si un paquet est cassé, c'est xorg-xinit.
Ce serait un /etc/group écrasé, pour les soucis de permissions.
Posted: Sep 23, 2011 6:58:25 am
Cereal-Killer
icon



je sais que ça fonctionne, mais seulement en root, donc je voulais voir les permissions de Xorg (et surtout le "s").
or vu le "cannot move old log file "/var/log/xorg.0.log" to "/var/log/xorg.0.log.old", il n'a pas le droit d'écrire dans /var/log, ce qui ne devrait pas arriver puisque par défaut Xorg est setuid-root.
si xorg-xinit était cassé, il aurait probablement un "startx : commande introuvable".
mais je peux me tromper...
Posted: Sep 23, 2011 6:51:09 pm
Calimero
icon



En effet, pas impossible, attendons voir la réponse.
Posted: Sep 24, 2011 4:39:20 pm
heretik
icon



pour la commande ls -> -rwxrwxrwx 1 root root 1950096 17 sept 19:44 /usr/bin/xorg

avec startx en root, j'ai un écran noir d'abord avec un curseur en haut à gauche, puis écran noir seul...

du coup, ça m'a rappelé mes anciennes expériences... j'ai installé xterm et refait startx en root, là j'arrive bien sur xterm.... et en tapant openbox-session, je retrouve openbox.... c'était juste pour essayer...et à titre informatif
!!__metal__!!
Posted: Sep 24, 2011 4:44:04 pm
heretik
icon



startx en user me donne toujours la même erreur...

avec /& pastebin ça donne -> [1] 5305 fatal server error: cannot move old log file
xinit giving up
xinit: unable to connect to x server
xinit server error

et comme en user et je dois faire ctrl c pour reprendre la main.

ce serait une histoire de droits de fichiers? ...

et je ne sais pas si c'est important, mais j'avais plusieurs logiciels d'ouvert lors du plantage... firefox, pcmanfm, lecteur de musique, et autres....

quoi qu'il en soit, merci de vos réponses , c'est sympa...

bon we :)
!!__metal__!!
Posted: Sep 24, 2011 7:46:15 pm
Calimero
icon



pas /& mais |& !! C'est pour pastebin le résultat, tu ça sort un lien et tu nous le donnes, enfin !

Bref, Cereal a raison, pacman -S xorg-server
Ton reboot violent s'est passé pendant la MAJ de xorg, probablement. Il n'a (va savoir comment) pas *du tout* les bonnes permissions. (ou alors tu t'es débrouillé pour mal nous recopier le résultat du ls -l)
Tu ne l'aurais pas chmod 777 ? Ça fait peur, là.

Si tu dois retenir une chose, c'est d'éviter les hard-reboot pendant une mise à jour… :)
Posted: Sep 25, 2011 8:10:43 am
Cereal-Killer
icon



en fait, j'avais pensé à plus vicieux que ça, mais je sais pas encore assez bien comment Pacman fonctionne; je m'explique: sous Debian, le gestionnaire de paquet ne peut pas installer de fichier éxécutable avec l'UID root (pour des raisons de sécurité je pense), et c'est le script post-install qui fait le "chmod u+s Xorg". Est-ce pareil avec Pacman ? auquel cas la MAJ a été interrompu avant le script post-install, donc pas les bons droits, et comme c'est quand même une version à jour qui est installée, un nouveau "pacman -Syu" ne corrige pas le tir...

en bref, l'éxécutable "Xorg" a trop de droit en écriture, mais il lui manque le principal: l'éxécution avec l'UID root, sinon sa taille est la bonne donc le fichier doit pas être endommagé.
comme dit Calimero, la ré-install de xorg-server devrait corriger ça (on aurait pu lui redonner les bons droits à la main mais c'est moins propre que de laisser faire Pacman).
Posted: Sep 25, 2011 1:55:16 pm
heretik
icon



bonjour :)

bon, bin maintenant ça 'marche' de nouveau :D  ... c'était bien ça!

sauf que bin ça me plonge dans un autre truc étrange..

...tous les logiciels que j'ai exécuté fonctionnent... sauf... le terminal ...et plus d'accès aux tty
...ainsi que les fonctions "redémarer" éteindre" et veille.
...je ne peux donc plus entrer de ligne de commande ... et je ne vous raconte même pas comment je vais devoir arrêter l'ordi ... j'ai peur d'avance pour le redemarrage demain lol!

une petite question, pourquoi la commande pacman -S a bien effectuée la 'correction' de xorg-server alors que pacman -Syu m'a eu aucun effet? à priori c'est pareil non?...
ou alors le fait de nommer un logiciel en particulier est plus efficace? 

déjà qu'avant je n'étais pas un crack, mais là avec cette histoire, chui vraiment perdu... ^^

en tout cas, merci à vous....(je ne le répéterais jamais assez ;)  )

edit: je viens d'essayer avec alt F2 et xterm dans la fenêtre et ça fonctionne, je vais pouvoir arrêter le système proprement
!!__metal__!!
Posted: Sep 25, 2011 6:30:31 pm
Cereal-Killer
icon



"pacman -Syu" met à jour, c'est à dire qu'il agit uniquement s'il trouve une version plus récente du paquet que celle qui est installé; avec "pacman -S" tu installes un paquet, et s'il est déjà installé, ça force la ré-installation.

pour tes autres problèmes, es-tu bien sûr de n'avoir rien modifié quand tu cherchais la solution pour Xorg ? ce que tu décris ressemble à un .xinitrc (mal) modifié (session lancée sans consolekit).
Posted: Sep 25, 2011 8:05:42 pm
Calimero
icon



Dans xterm, lance urxvt et vois quelle est l'erreur ?
Posted: Sep 30, 2011 4:03:05 pm
heretik
icon



salut :)

ok, merci pour l'info qui pourtant parait évidente ... j'aurais dû réfléchir, ou penser que ça réinstallait... :)

en fait c'est arrangé... ça venait bien d'un mélange dans les droits de fichiers...

je n'avais plus accès à mes disques dur connectés au moment du plantage et pour cause... comme utilisateur, groupe et autre, j'avais une série de chiffres o_O je ne sais pas d'où ils sont sorti, mais bon... ^^

j'ai vu aussi que lorsque j'ai fait une mise à jour Syu, j'avais sur qq répertoires, un message concernant les droits, 775 et fichiers 750

j'ai corrigé tout ça à la main et là ça roule correctement depuis! ... et c'est tant mieux :)

merci pour ton aide, ainsi qu'à Calimero c'est sympa ;)

je retourne sur l'autre topic ;)
!!__metal__!!
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst