CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Oct 04, 2011 9:21:36 am
S3B
icon



Bonjour
Je suis nouveau ici et très intéressé par CtkArch.
Mais voila j'ai un petit soucis.
J'ai lancé mon cd fraichement gravé , tout se lance parfaitement sauf qu'il m'est impossible d'avoir une interface graphique.
lorsque je lance openbox ,celui ci me renvoi :" Echec de l'ouverture de l'affichage depuis la variable d'environnement DISPLAY"
Je Précise également que je lance la session en désactivant le KMS (obligatoire, sinon je me retrouve avec un bel écran tout noir !)
Voila j'ai cherché sur le forum ,mais je n'ai pas vu de post similaire.
Petite précision également: Je suis un habitué des distrib plus accessibles , donc j'espère ne pas être passé a coté d'un problème "évident".
Merci d'avance.
Posted: Oct 04, 2011 4:27:27 pm
Calimero
icon



1/ Comment fais-tu pour « lancer openbox » comme tu dis ?
Je lis, hein : tu dis que tu lances openbox. Comment t'y prends-tu, exactement, concrètement ?

2/ Comment le message "Echec de l'ouverture de l'affichage depuis la variable d'environnement DISPLAY" s'affiche-t-il ? (fenêtre, tty, etc. préciser, si besoin avec une photo de l'écran !)

3/ Quelle est la carte graphique ?

Pour la précision, pas de lézard, si la question est évidente ça ne fera que rendre la résolution plus facile.
Posted: Oct 05, 2011 8:53:43 am
S3B
icon



1/ Une fois identifié via "root "validée avec MDP "toor" , Je tape tout simplement "openbox". A noter que j'ai également essayé  avec "openbox-session" qui me renvoie la même réponse.

2/ Le terme tty ne m'est pas étranger mais je ne connais pas sa signification exacte.Je viens de faire quelques recherches mais les explications trouvées ne m'ont pas parus très claires... Bref  ca s'affiche en ce que j'appelle moi , le mode console tout comme si j'étais dans un terminal.
( Est -ce similaire au tty?)
Bon la je n'ai pas de photo mais j'en ferais une si il le faut vraiment.

3/ Ma CG est une Nvidia GeForce 6150 LE.
Intégrée a la carte mère , Elle ne m'a jamais posé de soucis sur les autres distribs , supporte bien l'accélération graphique , mais toujours obligé de désactiver le KMS depuis son arrivée au sein de linux.

Voila, voila.
Posted: Oct 05, 2011 9:34:55 am
Calimero
icon



1/ Je m'attendais à un truc tordu de ce genre. Mauvaise méthode. On ne peut lancer openbox que dans Xorg. Nota : openbox n'est pas un bureau, il sert seulement à bouger les fenêtres, et ce, dans Xorg.

2/ Pas la peine, la réponse à la question 1 implique que ça s'affiche dans le tty (console virtuelle) où tu t'es logué.

3/ Si tu désactives le KMS avec nouveau, tu n'as en gros généralement pas la possibilité de lancer Xorg.
Xorg est le serveur graphique, dans lequel s'affichent les applis graphiques, y compris celles qui constituent le bureau (feh, openbox et fbpanel dans le cas de ctkarch)

Note qui m'a fait un peu rigoler, “au sein de linux”, il n'y a que du code C, pas des gens. À moins que tu sois écrit en C ?

Peux-tu lancer non pas openbox en te connectant dans le tty, mais plutôt X ?
Et regarder l'erreur.
Posted: Oct 05, 2011 12:07:57 pm
S3B
icon



Bon ok.
Je m'attendais aussi à me planter dans ma démarche.
j'utilise toujours en priorité une solution graphique dans mes taches du quotidien et forcément j'ai de grosses lacunes quand je me retrouve devant un petit curseur clignotant ...

Bref pour revenir a nos moutons , j'ai finalement opté pour le démarrage "pilote Xorg Vesa ( Secours, non accéléré )".
Et je suis enfin arrivé sur le bureau CTK Arch.
Vraiment désolé de ne pas avoir testé plus en avant les diverses options qui s'offraient , du coup je nous ai fait perdre du Temps à tout deux.
Après le truc de bien c'est que je l'ai finalement installé sur mon DD (Tout c'est passé nickel) , Donc peut être ouvrirais je de nouveaux posts si besoin pour parfaire cette install.
En tout cas Merci de ton aide.
Posted: Oct 05, 2011 3:05:06 pm
Calimero
icon



C'est pas génial vesa, ce n'est pas accéléré.
Je te suggère de mettre à jour et d'enlever le /etc/X11/xorg.conf.d/20-gpudriver.conf et l'option nomodeset dans menu.lst, pour voir si ça fonctionne avec linux 3.0 et le dernier Xorg.

ctkarch.org/forum/viewtopic.php?id=5&t_id=17
Posted: Oct 09, 2011 7:49:45 am
S3B
icon



OK.
J'ai installé nouveau pour Nvidia.Ça tourne nickel.  :) 
Posted: Oct 09, 2011 7:59:17 pm
Calimero
icon



En fait, nouveau était déjà installé, hein. Juste, il a été mis à jour et la nouvelle version est ok !
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst