CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Nov 03, 2011 4:58:01 pm
mandog
icon



i've setup ctkarch on usb the uk keyboard worked fine till i set it up for persistance now it shows up as set to uk at boot up but when it reaches the desktop it defalts to us layout, I installed xxkb but that does not even start fbxkb just shows us layout and does not switch the other one is dead. this is a blow as i need the uk keyboard layout. help would be appreiated. that apart GTKarch is  really  polished since the last time I tried it and fits the bill on this laptop as i need to use a stick for linux and the other flavours with persistance are a let down.
thanks
Posted: Nov 03, 2011 5:58:40 pm
Calimero
icon



1/ I'm interested to correct that if this is a bug. Can you put on pastebin the file /etc/X11/xorg.conf.d/10-evdev.conf on the live system with the persistant partition? Thanks.

2/ Whatever happens, as a workaround you can add setxkbmap gb at the end of ~/.config/openbox/autostart.sh on the live system with persistence.

3/ On the already installed system, you can edit /etc/X11/xorg.conf.d/10-evdev.conf and change "us" to "gb".
Posted: Nov 03, 2011 10:18:01 pm
mandog
icon



thanks for the quick reply

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
Option "XkbLayout" "us"
Option "XkbVariant" ""
Option "XkbOptions" "compose:menu,terminate:ctrl_alt_bksp,keypad:pointerkeys"

i'd forgten about putting add setxkbmap gb at the end of ~/.config/openbox/autostart.sh i was using code from the wiki but it works so thats OK with me
Posted: Nov 03, 2011 10:54:54 pm
Calimero
icon



Did you choose the UK keymap in the boot menu when you started the live system to copy the contents of 10-evdev.conf?
Posted: Nov 03, 2011 11:11:59 pm
mandog
icon



yes i did i set up another pendrive today checked Uk keyboard when desktop was running OK. Set up persistance and it defaulted to US as soon as i rebooted although the boot screen clearl said UK keyboard on boot desk top defaults to US.
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst