CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Dec 01, 2011 12:24:25 am
MisteRibi
icon



Bonjour,

J'essaye d'installer yaourt mais j'ai cette liste de conflit:
Quote:
[root@ctkarch mribionu]# pacman -Su yaourt
:: Début de la mise à jour complète du système...
:: Remplacer cyrus-sasl-plugins par extra/cyrus-sasl-gssapi ? [O/n]
:: Remplacer cyrus-sasl-plugins par extra/cyrus-sasl-ldap ? [O/n]
:: Remplacer cyrus-sasl-plugins par extra/cyrus-sasl-sql ? [O/n]
Avertissement: fbpanel: la version locale (6.1.507svn-2) est plus récente que community (6.1-2)
:: Remplacer heimdal par core/krb5 ? [O/n]
:: Remplacer kernel26 par core/linux ? [O/n]
:: Remplacer kernel26-headers par core/linux-headers ? [O/n]
:: Remplacer lib32-heimdal par multilib/lib32-krb5 ? [O/n]
:: Remplacer lib32-libjpeg par multilib/lib32-libjpeg-turbo ? [O/n]
:: Remplacer ndiswrapper-utils par community/ndiswrapper ? [O/n]
:: Remplacer pygobject par extra/python2-gobject2 ? [O/n]
résolution des dépendances...
recherche des conflits entre paquets...
Erreur: la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: aufs2: requiert kernel26>=2.6.37.3
:: aufs2: requiert kernel26<2.6.38
:: nvidia-173xx: requiert kernel26>=2.6.37
:: nvidia-173xx: requiert kernel26<2.6.38



J'ai commencé par install nvidia et galéré avec la partie conflit entre nouveau(même supprimé) et nvidia auquel une étape manque dans le wiki, celle avec la commande mkinitcpio. Après, j'avais réussi à installé yaourt mais je pouvais rien installé, même avec pacman, puisqu'il y avait un conflit entre deux paquets non mis à jour donc un qui était à «sa dernière version», donc j'ai désinstallé yaourt et les deux paquets(package-query et yajl). J'ai commenté la ligne du dépôt frozen et fait un -Syu, et ensuite j'ai essayé d'install yaourt comme ci-haut.

Ma question serait: que doit-je faire pour installer yaourt? Sans devoir réinstall et installé nvidia après avoir commenté le dépôt frozen et fait un -Syu? Sinon, c'est pas grave, faut juste que j'aille le temps :P

Sur ce, merci d'avance et passer une bonne journée, soirée ou nuit  (rofl)

Cordialement,
Posted: Dec 01, 2011 10:20:30 am
Cereal-Killer
icon



pour toutes les questions où on te demande de remplacer tel paquet par tel autre, tu peux répondre "oui".
pour tous les problèmes de mise à jour, voir ici.
pour installer un paquet, c'est "pacman -S <paquet>" (et pas "-Su <paquet>"), mais il est préfèrable de faire un "pacman -Syu" d'abord, pour mettre l'ensemble du système à jour.

je pense que ton problème vient du fait que tu as installé Nvidia avant de mettre ton système à jour, donc l'idée serait de désinstaller "nvidia-173xx", de mettre à jour le système, et d'installer le paquet "nvidia" (qui lui dépend du noyau 3.1 que tu auras après mise à jour); au passage, tu peux supprimer aufs2, pour que la mise à jour se fasse.

tuto nvidia ici
Posted: Dec 01, 2011 12:13:15 pm
MisteRibi
icon



Premierement, merci pour cette réponse rapide!

Deuxiement, j'ai désinstallé nvidia-173xx et aufs2, fait un -Syu mais a la vérification des conflits entre les paquets, j'obtiens cela:
Quote:
(462/462) analyse des conflits entre fichiers            [------------------------------] 100%
Erreur: la validation de la transaction a échoué (conflit de fichiers)
initscripts: /etc/profile.d/locale.sh est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/__init__.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/backend.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/configmanager.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/dbusmanager.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/logfile.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/misc.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/networking.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/wnettools.pyo est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/wpath.pyo est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n'a été mis à jour.




Sur ce, merci d'avance et passer une bonne journée, soirée ou nuit 

Cordialement,
Posted: Dec 01, 2011 2:02:00 pm
Cereal-Killer
icon



tu fais un "pacman -Sf wicd" et un "rm /etc/profile.d/locale.sh", ça devrait rouler (mais tu pourrais aussi aller lire les liens que je t'ai donnés: la soluce était dedans).
si ça marche pas, j'avais aussi une autre méthode:
-désinstalle Wicd (pacman -Rs wicd)
-fais ta mise à jour (pacman -Syu)
-ré-installe Wicd et Wicd-gtk (pacman -S wicd wicd-gtk)

si ta connection internet n'est plus active après avoir désinstallé Wicd (normalement ça n'arrive pas mais on sait jamais), ce n'est pas grave: les paquets dont tu as besoin sont déjà téléchargés (dans le cache).

par contre, évite de redémarrer tant que tu n'as pas installé le driver nvidia (quoique faire la mise à jour sans serveur X ne soit pas si gênant que ça)
Posted: Dec 01, 2011 4:25:20 pm
Calimero
icon



Tu n'as vraiment pas lu le lien donné par Cereal, misteribi. Le premier.
Quote: Cereal-Killer at Dec 01, 2011 10:20:30 am
pour toutes les questions où on te demande de remplacer tel paquet par tel autre, tu peux répondre "oui".
pour tous les problèmes de mise à jour, voir ici.


Tout est expliqué.

Si tu n'as pas lu parce que c'était en anglais, ctkarch.org/news/upgrade/
Posted: Dec 01, 2011 9:35:12 pm
MisteRibi
icon



Merci pour vos réponse et si je n'ai pas lu c'est parce que j'avais pas vu qu'il y avait un lien, mais faut dire que je venais de me réveiller et que j'étais préssé :/ J'aurais du être patient!

Sur ce, merci encore :D

Cordialement,
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst