CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Apr 05, 2012 1:04:21 am
eric
icon



bonjour calimero et a la communauté,

en premier lieu : super boulot, dans l'esprit de arch, simple, rapide, clair parfait quoi et d'une installation tres plaisante.

bon j'ai quand meme un probleme de mise a jour. j'ai lu ton topic http://ctkarch.org/news/upgrade/.

j'ai donc supprimié aufs et ndiswrapper mais lorsque je fais une mise a jour avec -Syu j'ai un conflit avec glibc. je précise je vient tout juste de l'installer sur le disque.

je voudrais pas mettre le souk dés le départ, donc un petit coup de main serait pas de refus.

Attached File(s)miseajour.png (51KB / 475 Downloads)

Posted: Apr 27, 2012 9:01:55 am
Calimero
icon



Je rajoute ce qu'il faut dans le tutoriel.
Posted: Apr 28, 2012 7:56:54 pm
stef
icon



Bonjour,

Je viens d'installer Arch 0.7, et j'ai été confronté au problème de mise à jour.
Après avoir pas bidoullé dans tous les sens, j'ai décidé de repartir sur une base propre et de résoudre le problème de mise à jour dans la version live avant de faire l'installation sur mon disque.
J'ai donc suivi le tutoriel qui indique de supprimer aufs2 et ndiswrapper, puis de refuser la mise à jour de pacman en premier. Mais j'obtiens  le même message d'erreur sur libgl=7.10.1



D'avance merci, et encore bravo pour votre liveCD.

Attached File(s)screenshot.png (76KB / 449 Downloads)

Posted: Apr 29, 2012 10:48:41 am
Calimero
icon



stef: il faut suivre le guide sur ctkarch.org/news/upgrade
Bien toutes les commandes dans l'ordre sans en oublier, et sans redémarrer en plein milieu.
Posted: Apr 29, 2012 6:53:15 pm
stef
icon



Encore merci, effectivement, avec un peu d'attention et en suivant à la lettre, ca fonctionne très bien.  (crazy) 
Posted: Sep 11, 2012 10:23:49 am
jibe
icon



Salut,

Je viens d'installer CTKarch que je découvre. Aucune expérience d'ArchLinux.

J'ai voulu mettre à jour en suivant le tuto indiqué, mais j'ai des soucis...

1 - L'indication de où trouver mirrorlist éviterait d'avoir à la chercher. Pas grave, on se débrouille, mais ça nous éviterait de torturer Google  ;) 

2 - Il n'est pas précisé ce qu'il faut répondre (ou faut-il que je change mes lunettes ? Pas trouvé...) quand on a lancé pacman -Syu et qu'il dit qu'il faut d'abord mettre à jour pacman, yaourt et package-query. Il m'a paru logique de répondre par oui (j'ai découvert ce fil après coup !), et du coup je me retrouve avec un conflit avec glibc...

Comme j'ai vu qu'il ne fallait pas redémarrer en cours de procédure, j'attends de savoir quoi faire maintenant (si quelqu'un passe assez vite...). Je suppose qu'il suffit de relancer pacman -Syu en répondant "non" cette fois à la question des mises à jour prioritaires ?

A toutes fins utiles, voici les commandes et résultats :
SH Code:
[root@ctkarch bjboy]# pacman -R aufs2
Vérification des dépendances...
 
Suppression (1): aufs2-2.6.37_20110124-4
 
Taille totale des paquets (suppression):  0,14 Mo
 
Voulez-vous désinstaller ces paquets ? [O/n] O
(1/1) Désinstallation de aufs2                      [--------------------------] 100%
[root@ctkarch bjboy]# rm /usr/bin/tzselect /usr/sbin/zdump /usr/sbin/zic
[root@ctkarch bjboy]# pacman -Syu
:: Synchronisation des bases de données de paquets...
core                    107,0K  139,0K/s 00:00:01 [--------------------------] 100%
extra                  1422,8K  480,9K/s 00:00:03 [--------------------------] 100%
community              1778,3K  478,4K/s 00:00:04 [--------------------------] 100%
archlinuxfr              36,1K  407,1K/s 00:00:00 [--------------------------] 100%
:: Les paquets suivants devraient être mis à jour en premier :
    pacman  yaourt  package-query
:: Voulez-vous annuler l'opération courante et
:: mettre à jour ces paquets maintenant ? [O/n] O
 
Résolution des dépendances...
Recherche des conflits possibles entre paquets...
 
Cibles (8): linux-api-headers-3.5.1-1  glibc-2.16.0-4  libarchive-3.0.4-1
            archlinux-keyring-20120812-1  pacman-4.0.3-3  yajl-2.0.4-1
            package-query-1.0.1-1  yaourt-1.1-1
 
Taille totale des paquets (téléchargement):  9,92 Mo
Taille totale des paquets (installation):  45,81 Mo
 
Procéder à l'installation ? [O/n] O
:: Récupération des paquets du dépôt core...
linux-api-headers-3...  607,7K  330,9K/s 00:00:02 [--------------------------] 100%
glibc-2.16.0-4-i686        7,8M  611,8K/s 00:00:13 [--------------------------] 100%
libarchive-3.0.4-1-i686  633,4K  376,7K/s 00:00:02 [--------------------------] 100%
archlinux-keyring-2...  326,6K  268,9K/s 00:00:01 [--------------------------] 100%
pacman-4.0.3-3-i686      523,2K  343,9K/s 00:00:02 [--------------------------] 100%
:: Récupération des paquets du dépôt community...
yajl-2.0.4-1-i686        36,6K  93,6K/s 00:00:00 [--------------------------] 100%
:: Récupération des paquets du dépôt archlinuxfr...
package-query-1.0.1...    21,1K  302,5K/s 00:00:00 [--------------------------] 100%
yaourt-1.1-1-any          44,7K  612,5K/s 00:00:00 [--------------------------] 100%
(8/8) vérification de l'intégrité des paquets      [--------------------------] 100%
(8/8) Analyse des conflits entre fichiers          [--------------------------] 100%
Erreur: la validation de la transaction a échoué (conflit de fichiers)
glibc: /lib est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n'a été mis à jour.
[root@ctkarch bjboy]#


Offtopic: Il est où, le bouton "Code" ? Il faudrait le mettre à la place du bouton "offtopic" qui ne serait alors plus utile  ;)    :D 
Posted: Sep 11, 2012 6:46:19 pm
jibe
icon



Bon, comme en principe rien n'avait été effectué, j'ai tenté de refaire un pacman -Syu, cette fois en refusant les mises à jour prioritaires. Je me retrouve là aussi avec des erreurs dont je copie une partie :
SH Code:
(637/637) Analyse des conflits entre fichiers      [--------------------------] 100%
Erreur: la validation de la transaction a échoué (conflit de fichiers)
glibc: /lib est déjà présent dans le système de fichiers
krb5: /etc/krb5.conf est déjà présent dans le système de fichiers
krb5: /usr/bin/kdestroy est déjà présent dans le système de fichiers
...
krb5: /usr/share/man/man8/kadmind.8.gz est déjà présent dans le système de fichiers
filesystem: /etc/mtab est déjà présent dans le système de fichiers
filesystem: /etc/profile.d/locale.sh est déjà présent dans le système de fichiers
filesystem: /var/run est déjà présent dans le système de fichiers
wicd: /usr/lib/python2.7/site-packages/wicd/__init__.pyo est déjà présent dans le système de fichiers
...
 
wicd: /usr/lib/python2.7/site-packages/wicd/wpath.pyo est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n'a été mis à jour.

Je n'ai pas /etc/pacman.conf.pacnew, donc je ne peux pas continuer normalement le tuto...

Un petit coup de main serait le bienvenu ! Dois-je exclure, comme je l'ai lu quelque part (forum ou wiki arch probablement) les paquets glibc, krb5, filesystem et wicd lorsque je lance pacman -Syu ? J'hésite, puisque ce n'est pas indiqué dans le tuto...
Posted: Sep 26, 2012 8:25:13 am
Calimero
icon



Les instructions du RSS ne sont plus à jour, et par ailleurs la mise à jour casse l'autologin.
Je compte les mettre à jour, quand j'aurai trouvé une solution au problème.
Ça va devenir un script énorme…

En attendant, l'utilisateur averti appliquera les conseils qui sont dans les news archlinux.org ou .fr…


L'explication préliminaire de la procédure et l'adresse complète de mirrorlist sont dans la documentation, je n'ai mis qu'un rappel pour les oublieux dans le RSS, après plein de sujets "yaourt package-query oscour".
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst