CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Jul 31, 2012 10:38:14 pm

Hello all,
As someone tried to upgrade the live system on virtualbox?
I tried several way but when it come to the upgrade of filesystem, i get an error : "boot is not writable"
I guess it may come from the fact that I've launched from an iso file...
I tried to dd it inside vbox but I didn't manage to launch it...
I would really appreciate if someone as a solution or at least advices

Posted: Aug 17, 2012 1:13:46 pm

You are trying to update a live system.
I'm sorry, but what you're doing is plain nonsense. :)

You may update an installed system, but not the running live-cd.

PS: this has absolutely nothing to do with virtualbox.
Posted: Sep 03, 2012 1:17:21 pm

Thank you for your asnwer Calimero.
I've just seen it. It seems that I can't find how to observe a thread ^^"

However my objective is to use CTKARch live to build my own personalized arch.
Many things have changed since the last version of ctkarch and I don't want to have to do every tips to get ctkarch updated every time.So i planned to first update the last version, create an addon or a new live cd.
And then install and configure it to my use for creating an addon or a new live cd.

Is there a better way to do it?

Thank you
Posted: Sep 05, 2012 6:44:28 pm

Ah, I'm afraid you can't update the livecd with an addon! The kernel needs the AUFS module, and you must rebuild the livecd's initrd with the udev and modules of today.
The scripts must be adapted for this, as well.

In other words: only solution would be a new version of the livecd.
I was on the brink of doing one, but ArchLinux has gone crazy with systemd and stuff, so I'm waiting for things to settle a bit, for the new version to stay up durably (installation and upgrades, I mean), as 0.7 did, quite properly, until some time ago.
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst