CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Apr 16, 2011 8:23:38 am
aus9
icon



Hi

I am new to CTK and ARCH and booted live cd 0.7 32 bit

PHP Code:
[root@ctkarch drivers]# vi /etc/locale.gen
[root@ctkarch drivers]# locale-gen
Generating locales...
  en_AU.UTF-8... done
Generation complete.
[root@ctkarch drivers]# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
 
 
tail -n 10 /var/log/messages.log
 
Apr 16 07:12:56 localhost dhcpcd[1933]: eth0: leased 192.168.1.1 for 43200 seconds
Apr 16 07:12:56 localhost dhcpcd[1933]: forked to background, child pid 1955
Apr 16 07:19:22 localhost -- MARK --
Apr 16 07:39:22 localhost -- MARK --
Apr 16 07:59:22 localhost -- MARK --
------------------------> nothing helpful here?



2) AFAIK I can see the following files and their contents but not sure which is over riding what

a) /etc/locale.gen

ls -al /etc/locale.gen
-rw-r--r-- 1 root root 858 Apr 16 08:11 /etc/locale.gen

b) /etc/profile.d/locale.sh

contents includes export LANG=en_US.UTF8

c) /etc/rd.d/functions

section on sanitize locale settings

3) If its not a bug but a feature.....well fair enough

4) What I am hoping to do.....is not just remaster but remaster with my locale settings already set to AU

If I need to run a rc.local ......let me know

but not sure if it will work if I can't get locale-gen to work with root  powers

Low priority of course

regards
Posted: Apr 16, 2011 9:41:04 pm
Calimero
icon



Is that on the live system, or installed?

Absolutely speaking, you need to have LOCALE="en_AU.UTF-8" in rc.conf.
Of course, on the live system it causes a little problem: rc.conf is set at each boot with the commandline options passed by the bootloader.
That means you need an add-on containing:
etc/rc.conf (with your modif)
etc/rc.d/functions.d/.wh.rcconfset (that deletes this file so it doesn't erase the rc.conf you included)

PS: not a bug. moving to User support.
Posted: Apr 17, 2011 4:50:21 am
aus9
icon



hi

well I just found out I do not understand the documents .....grins sheepishly

ok so here is where I am at

1) boot live 0.7 cd into ram 2) run wicd to connect network (for me wired eth router which has its own DNS etc)
2) command yaourt isomaster
3) (Alt/F2)= run    urxvt -pe tabbed 
4) PHP Code:
su
/addons/mkaddon
I chose name "locale-installable" and default to /tmp build directory


In second tab
PHP Code:
su
vi /etc/rc.conf
(edit line to au)
cat /etc/rc.conf | grep UTF
LOCALE="en_AU.UTF-8"


Now using a file manager I can see

/tmp/addon-locale-installable has a subfolder called root

running file against that root says its a sticky directory.....hmmm

So I assumed to add files to my addon I do this?

PHP Code:
mkdir -p /tmp/addon-locale-installable/etc/rc.d/functions
cp /etc/rc.conf /tmp/addon-locale-installable/etc/
 
(yes looks good)
 
cp /etc/rc.d/functions.d/rcconfset /tmp/addon-locale-installable/etc/rc.d/functions/.wh.rcconfset
cp: accessing `/tmp/addon-locale-installable/etc/rc.d/functions/.wh.rcconfset': Operation not permitted


sorry if my eysight has missed something

what I assumed was that if I put these files into their pretend file structure I could then complete the addonscript

-------------------------------------------------------------

I could just add a
/bin/rm -f /etc/rc.d/functions.d/rcconfset
to rc.local but then why have .wh.filenames?


low prority

regards
Posted: Apr 17, 2011 6:33:31 am
aus9
icon



oops I should not have used that filename as
installable: adding “installable” at the end of the addon’s name will cause the installer to ask if it must be installed. Don’t do this with an add-on designed to run in live only.

However I don't think it affects the actual error in trying to use
dotwhdotrcconfset
Posted: Apr 17, 2011 1:25:50 pm
aus9
icon



hi

just unpacked the packer addon and it looks like there is no root subfolder so either that is the top level or I am to remove that folder

still not clear but I can't find any .wh* files in the unpack

oh well I will have a another go during the Easter break
Posted: Apr 18, 2011 2:34:39 pm
Calimero
icon



The root subfolder in the workdir is the folder corresponding to… guess what, the root of the add-on.
The root folder will be compressed to the add-on. If you copy stuff to /tmp/addon-something/ it won't be in the add-on, that's all and that's why.

People seem to be fond of complicating things if they can. When mkaddon says it supplies a shell in the root folder of the addon, that's what it does.
So when you get the shell, just do:

mkdir -p etc/rc.d/functions.d
touch etc/rc.d/functions.d/.wh.rcconfset #if you don't do this, your rc.conf will be overwritten at boot
cp /etc/rc.conf etc/
vi etc/rc.conf #and change the locale and keymap to what you want


Done. Why did you try strange things?
Posted: Apr 22, 2011 1:08:36 am
aus9
icon



hi

why do I do strange things....must be because I am complete weirdo.....grins like a sheep

1) ok having some trouble with both urvxt and roxterm in live boot cd into ram

when I go into vi to edit the file.....I am used to seeing that I am in "insert" mode as showing in attached images from a Debian distro

vi images deleted as no longer relevant

Let me know if your shell shows visual feedback please.

2b) ....now because I could not see where I was ....I got into some kind of buffer problem inside vi and it crashed on me so I used leafpad instead...called from inside the mkaddon shell ok?

EDIT

oops I should add the squashfile to show it looks ok?

EDIT

file deleted will update link later
Posted: Apr 22, 2011 1:54:09 am
aus9
icon



hi

silly me

I forgot to change the file permissions so iso now starts in vbox

2) Now the only EDIT 2  issues are 

1)  screenshot for the locale command showing there are some gremlins? or not?

2) The issue for insert mode for your shell and vi

(above post has been reduced in size to account for my waffle)

EDIT try out new image server for locale image

Posted: Apr 22, 2011 7:47:26 am
Calimero
icon



You didn't include the generated locale.
Add /usr/lib/locale/locale-archive to the addon after editing /etc/locale.gen and generating the en_AU locale (locale-gen).

I don't know vi and don't see the problem on your screenshots...
And why do you use filedropper? It's really a pain. Use ompldr.org
Posted: Apr 22, 2011 10:20:27 am
aus9
icon



hi

thanks for the speedy response

2) I used filedropper because I saw someone else had used it

3) since you don't use vi my question becomes irrelevant

fair enough

EDIT

I have removed insert mode images to save your server space, and updated locale image to link to external file share site as suggested.

Filedropper link deleted as file deficient will link to ompldr.org later

regards
Posted: Apr 23, 2011 9:46:05 am
aus9
icon



hi

locale updated as per suggestions and minor change I included a smaller version of /etc/locale.gen and here is the new test




2) squashfile is here

ompldr.org/vOGUydA

I have not completed all tests but will do so within 2 days ....so far so good
Posted: Apr 23, 2011 11:38:35 pm
aus9
icon



hmmm 

when I first tested in vbox all I did was to test the locale

Next I burnt it and here are my results

1) at boot up I can see about 5 or more lines talking about /etc/rc.sysinit errors

a) obtained normal graphical environment and locale reports are good as above but

2) Initially clicking to the menu for applications.....menu refuses to cascade

I am aware of scrot but for now will merely describe my errors

3) when the cascade eventually worked....no matter how many times I clicked on
-> internet -> wicd

the wicd icon at bottom right hand corner does not appear

4) I have yet to find those sysinit errors in the log but will look again later after seeing if I need a syslog cheatcode of larger size?

5) pressing control/alt and F1 took me to the tty login screen and did not show any of the messages I that I used to seeing on a boot up of a hard drive distro

I might have to look at some syslog cheat codes?

also pressing control alt and F5 takes me back to the graphical screen while I am used to seeing that on a hard drive distro at f7

This is not meant to sound like a critical comment ok? I am just reporting on my locale failure and I know I have more work to do before its solved.

If I never find those errors in the log I will use a camera to photo them in case they are useful.

6) My weaknesses include: am new to CTK and am not a programmer so not so good at reading scripts etc

But I lke the feature of addons as an easier way to remaster live cds so will persist even if I am appearing to be a troll or some other nasty beast in the eyes of CTK users.

regards

more testing later
Posted: Apr 23, 2011 11:55:35 pm
aus9
icon



ok so booted back into "normal" ctk iso

here are some logs

/var/log/erros.log

ompldr.org/vOGU5Mg/errors.log

/var/log/messages.log

ompldr.org/vOGU5Mw/messages.log

Note these are for a good working boot up with the net, with cascading menu etc

I shall post from the remaster later

and in case some one spots something here is the /etc/rc.sysinit

ompldr.org/vOGU5NA/rc.sysinit
Posted: Apr 24, 2011 5:42:45 am
aus9
icon



ok rebooted into remaster and guess what...no logs

instead I used

PHP Code:
ls -al /var/log > (mountedpartition)/log


on reboot into hard drive distro its contents reads

-----------------------------------
total 76
drwxr-xr-x  6 root root    100 Apr 24 00:00 .
drwxr-xr-x 17 root root    100 Dec  2 05:19 ..
drwxr-xr-x  2 root root      3 Feb  2 04:15 ConsoleKit
-rw-r--r--  1 root root  31105 Apr 24  2011 dmesg.log
-rw-r--r--  1 root root 292292 Apr 24 00:00 lastlog
drwxr-xr-x  2 http http      3 Mar 17 01:58 lighttpd
drwxr-xr-x  2 root root      3 Dec 14 15:09 old
drwxr-xr-x  2 root root      3 Apr  6 18:41 wicd
-rw-r--r--  1 root arch  30123 Apr 24 00:00 Xorg.0.log

The dmesg log from a normal iso appeared to be no different from the remaster

I do not know how to read the lastlog

but I am missing syslog messages etc

2) I tried to snapshot with my camera the errors on booting up the kernel and its init scripts and errr I am not good at hand held

instead I rebooted and read the errors were about 20 odd lines that appeared to start with

/etc/rc.sysinit lines 9 12 13 14 16 66 68 70....and more and ended about 178

3) Rather than try to solve that myself I shall be boring and redo all of my locale squashfile from a true iso in live mode
then compare it to what I uploaded....maybe there is a difference?

4) Just to repeat a few tests I did on a couple of reboots

a) still no access to internet by cascade menu to applications ....internet ....wicd

b) still no cascading menu at very beginning of desktop for the applications....but it does cascade for the "desktop" and other menu items
In other words there is something happening at the top menu cascade but all others work

c) for reason I know not....the top cascade eventually works but the wicd daemon does not

I could try....su ....ifconfig eth0 up ....but I am not going to....I have decided this remaster is not worth testing any further so need to do a rebuild


d) I have just noticed the rc.sysinit has these lines which interest me

(starts line 156 which altho I did not state above.....could be ...could be...I hope.....yes I waffle on

# Flush old locale settings
: >| /etc/profile.d/locale.sh
/bin/chmod 755 /etc/profile.d/locale.sh
# Set user defined locale
[[ $LOCALE ]] || LOCALE="en_US"
stat_busy "Setting Locale: $LOCALE"
echo "export LANG=$LOCALE" >>/etc/profile.d/locale.sh
stat_done

EDIT

e) just noticed inside rc.syint

line 36......

/bin/dmesg -n 3

I shall try changing this at same time of remaster to use

linux.die.net/man/8/dmesg

/bin/dmesg -s 16392


As I have nothing to lose......and no shame.....I shall edit these lines out and add the file to my remaster and hope is was the cause of my little issue?

regards
Posted: Apr 24, 2011 9:53:53 am
aus9
icon



ok still fumbling in the dark due to my poor skils

now I am looking at these lines in /etc/rc.sysinit
# Flush old locale settings
: >| /etc/profile.d/locale.sh
/bin/chmod 755 /etc/profile.d/locale.sh
# Set user defined locale
[[ $LOCALE ]] || LOCALE="en_US"
stat_busy "Setting Locale: $LOCALE"
echo "export LANG=$LOCALE" >>/etc/profile.d/locale.sh
stat_done

hmm no idea really but I then unpacked the squashfile and looked into the root-image.sqfs and in particular I see

PHP Code:
squashfs-root/etc/profile.d$ ls -al
total 28
drwxr-xr-2 root root 4096 Apr  6 18:40 .
drwxr-xr-x 52 root root 4096 Mar 30 04:47 ..
-rwxr-xr-1 root root  28 Nov 14 23:50 glib2.csh
-rwxr-xr-1 root root  28 Nov 14 23:50 glib2.sh
-rwxr-xr-1 root root  102 Nov 20 16:16 gpm.sh
-rwxr-xr-1 root root  678 Jan 28 01:22 perlbin.sh
-rwxr-xr-1 root root  396 Mar 18 19:39 xorg.sh


so I can not see any locale.sh in here ?

Now I attempted to remaster with a changed line from [[ $LOCALE ]] || LOCALE="en_US" to [[ $LOCALE ]] || LOCALE="en_AU"

but that got me into a message that $LANG had not been set....written in French AFAIK

This is getting beyond my skill level so will have to sign off until I get help if available

sorry to be verbose and trying everyone's patience....if anyone is still reading this....heh heh

good bye for now

and I have no idea if this is relevant or not but a google shows this link

mailman.archlinux.org/pipermail/arch-general/2010-September/016216.html

which claims maybe

Quote:

changing some code in /etc/profile:

49 if test -d /etc/profile.d/; then
50     for profile in /etc/profile.d/*.sh; do
51       if [[ $profile == "/etc/profile.d/locale.sh" && -n $DISPLAY ]]; then
52           continue
53       fi
54         test -x $profile && . $profile
55     done
56     unset profile
57 fi


Posted: Apr 25, 2011 1:54:04 pm
Calimero
icon



You're searching in the wrong direction.

The only problem is that you included a directory named
/etc/rc.d/functions/
instead of
/etc/rc.d/functions.d/

So, the file /etc/rc.d/functions is overwritten by a directory containing the .wh.rcconfset file.
You messed up with the filename when creating the add-on, that's all.

Also note that the KEYMAP should be "us", and not "us-pc" (this keymap doesn't exist).
Posted: Apr 25, 2011 10:51:28 pm
aus9
icon



ahhh

I am unworthy

thanks for spotting my mistakes.

Unfortunately I am now working on a different distro as I realised I had more experience with remastering something that I knew

good luck with your project
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst