CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Apr 22, 2011 10:16:44 am
aus9
icon



Hi

I am new to CTK and Arch but please don't hold that against me....heh heh

however I am now looking at adding a package thru the live 0.7 cd 32 bit and not sure what to do at a certain point

PHP Code:
su
/addons/mkaddon
(select) Install packages


So in a new terminal I installed my target addon called partimage and noted its dependencies

Now typing without the  quotes in the mkaddon root shell and pressing enter....does not give a response to "partimage" or "partimage-0.6.9-1"

ok so I tried pressing the ESCape key and also tried typing exit

any clues on how to exit entering a package name and finishing the script?

I am not a script guru so although I can read your script I am failing to understand the
http://ctkarch.org/documentation/0.7/rfc-addons.php?en

regards
Posted: Apr 22, 2011 8:53:24 pm
Calimero
icon



I don't understand what you're trying to do there.
If you want to add packages into an add-on, just use the menu item for that, type the name of the package(s) to add, and after that choose the finish option. The end.

PS: post moved to User support, this is not a shared add-on project.
Posted: Apr 22, 2011 11:48:29 pm
aus9
icon



hi its Mr stupid again .....grins like a sheep

nope I think we are on different planets so lets try that by images and you tell me how to get to the finished menu that I know about but can not get to please

1) I have changed target addon to one with no dependencies to keep it simple



2) start mkaddon script with root powers choose the first option rather than the second to keep it simple no?



3) From the menu I know the correct spelling of the packagename mtPaint



4) Now I am stuck.......what do I do to get to the main menu please?

Pressing the escape or typing exit and enter does not appear to work the same as the root shell



regards
Posted: Apr 25, 2011 1:31:31 pm
Calimero
icon



One might laugh seeing your last screenshot. :)
Please read the question and answer properly.
You have to answer the question about dependencies resolution before entering the name of the packages to include.

Also note that there never is any uppercase letter in the packages' names.
Posted: Apr 27, 2011 1:11:58 pm
aus9
icon



hi

ignoring the fact that I am no longer attempting to remaster your project (I am remastering tinycorelinux) can I make the following observations

1) You appear to suggest that the text
"avoid including dependencies already included in :
1
2
3 etc

is to be read as a question?

Is that what you meant?

Well b&gger me!

I thought it was information like

To pick up French females :
1 Be confident
2 Be witty
3 Have a nice smile

not a question at all....but thats my lack of understanding Englist

I hope you are laughing when you see why I did not read and understand you were asking a question

b) Why did I write mtPaint....because you told me to ....just use the menu item for that, type the name of the package(s) to add......and the menu item is mtPaint and not mtpaint

good bye
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst