CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: May 11, 2011 6:47:31 am
benbois
icon



Hi,

First, thank you for this great live Arch!

I installed it on a old Sony VAIO PCG-SRX51P.
Everything works except the wireless card.

the model with pccardctl ident

Socket 0:
  no product info available
Socket 1:
  product info: "Lucent Technologies", "WaveLAN/IEEE", "Version 01.01", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)


I copy agere_sta_fw.bin in /lib/firmware/ as described in this page linux.bplaced.net/srx51p/
After reboot, I tried to connect to a WEP protected wlan without success. I also tried one with WPA2 protection without success too.

I can see the orinoco_cs module with the lsmod command.

Help will be appreciated.
Cheers,
--
Ben
Posted: May 11, 2011 12:44:00 pm
Calimero
icon



Copying files anywhere else than in your home folder is never a good idea, it's really unclean and will just cause trouble.

Give the result of lspci |grep Net ?
Posted: May 11, 2011 3:28:30 pm
benbois
icon



Thanks Calimero for your reply.. 

On continue en FR ;-)

Ça va être un peu compliqué de coller le résultat des commandes, je n'ai pas le net sur le laptop.

lspci | grep net = rien pour la carte wifi (connectée en pcmcia)

lspcmcia = Socket 1 Device 0: [orinoco_cs] (bus ID: 1.0)
Posted: May 17, 2011 8:48:18 pm
hydro
icon



The firmware file is now included in the Arch package linux-firmware, I don't know if it's available in CTKArch.
The firmware is only required for WPA. If you want to use WEP, try deleting the firmware file (or uninstall the firmware package).
The orinoco_cs module does not support WPA2.
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst