CTKArch · Forums
You are not logged in. Please Register or Login.  |  Search
Posted: Feb 08, 2011 4:54:48 pm
alacszoli
icon



Does anybody have some experience about installing this printers on CTKArch (0.6 64 bit)? I've installed cups, hplip, udev. hp-setup properly recognize the printer, but when it start to download plugin from HP's site it crashes. I've installed Chakra and have almost the same problems but it works now and I don't know why. I would like to switch back to CTKArch but the printig support is a must to me.
Posted: Feb 13, 2011 12:54:54 pm
Calimero
icon



What are you downloading from the site of HP?

Remember: a distro has a package manager. You must *not* install anything without using it.
Anyway... this question is general on Arch Linux and maybe even on cups in general.

So. As usual. Cups support, totally non CTKArch-related.

Please first find your printer here: http://www.openprinting.org/printers
Is it a laserjet 1018? 1020? P1020?

For laserjet 1018/1020 the driver can be installed running yaourt -S foo2zjs
Maybe you'll have to install foomatic-db-foo2zjs as well.

Then it just works as on any other distro.

[EDIT] : no answer, assuming solved. It would have been nice to say if it works…
Posted: Feb 22, 2011 5:06:13 pm
alacszoli
icon



Well, it does not work.
The package foo2zsj, (yaourt -S foo2zsj) does not work properly ( the installation). I've tried to see on arch's website but I'm a newbie so this messages does not help much. The printing does work for me only if I install the hplip package (on other distros). This package on CTKarch produce some message about communication error. I'm going to wait for 0.7 version, right now I don't have much time to work on this issue. I'm printing under WinXP, for now.
Posted: Feb 23, 2011 11:48:11 pm
Calimero
icon



I'm afraid a new version won't magically solve your problem.
Generally speaking, a problem must be *first* solved and *then* its solution merged.
I'll add that there is nothing for cups in ctkarch : this topic is purely Arch (or even cups) related. ;)

Anyway, the problem is that I can't help you, because you didn't give any precise info.
You must post (pastebin) the *exact* errors you have when trying to print, otherwise no one can help you!
Posted: Mar 07, 2011 9:22:02 pm
Bra1n0v3rfl0w
icon



Hi,

The Hp 1018 is a bad printer. My father has it. I installed VectorLinux on his computer, and hplip is necessary.

The worst thing of such printer is that don't have a ROM for firmware, so every time you switch it off and then switch on you must load the firmware (from a file to the printer), and this is done by hplip.

If you switch on your win xp and after all system is loaded, if you switch off the printer, wait 10/20 sec and switch it on again, it will not work (at least this is what happens on my father pc).

I don't think you can do it in a different way. Anyway in next future as soon I will be more comformtable with CTK Arch Linux, I will install it on my father pc and let you know how I did.

Is surely NOT an OS problem!
Posted: Mar 11, 2011 6:29:26 am
alacszoli
icon



Today, two strange things happened to me. First I've downloaded the 0.6 64bit version and it has just installed fine without any Grub issues. Every time I've tried before, I have to manually install grub. The second thing is that HPLaser 1018 now works. I don't know why, maybe it is a new version in the repo but the procedure was:
pacman -Syu
pacman -S cups
pacman -S hplip
after this hplip package recquire python dbus and gobject dependencies. I hope that this is correct (I still have to learn many things about Arch).
hp-setup -i finished with a message that some of those two packages are not installed. On the Arch's forum it is a small note about python 3 and python 2 versions and a suggestion to change link in /etc/bin/python to the older (2.7) version. After that I've run hp-setup -i again and it works now. I would like to Calimero or someone else who can correctly explain my steps correct my message for  anybody else with this problems.
Calimero I do not belive in magic either, I've just ask for a help. Never says that this is your problem, don't take everything personally.
Posted: Mar 11, 2011 9:05:59 pm
Calimero
icon



Okay… strange that it worked on the 64-bit version and not 32bit…
For the grub install not freezing, it's because of the partitioning. xfs_freeze is run even when there is no xfs partition, but it sometimes hang and sometimes not. (that is fixed for next version of course!)

I'm like this, when someone asks something I precise things the most I can! Maybe the way I put it seems too direct.

Happy for you it works now! Sometimes, hardware is just horrible. (generally when it is poorly-documented)
(I have a printer that works on 64bit and not 32bit too, lexmark z11)
Powered by myUPB v2.2.7  ·   Creative Commons License PHP Outburst